WDCP面板环境PHP5.3快速安装pdo_mysql组件技巧

发布时间:2015-05-11 14:57:02

这几天老蒋都在折腾WDCP面板环境,这些东东看似比较简单,而且也提供一键安装包以为就这么安装就完事,但真正遇到问题是在过程中。比如一个朋友的网站程序需要支持pdo_mysql组件才可以安装,而且之前告诉我是只要PHP5.3版本就可以,我也帮他安装了PHP5.3(WDCP升级PHP5.3),但是查阅网上的很多教程都无法再PHP5.3的基础上安装PDO_MYSQL组件。

今天从上午到下午,在网友的帮助以及查阅且翻遍所有的网络教程,都没有解决99.999%都是错误误导大家的,比如下载所谓的PDO_MYSQL-1.0.2文件,然后进行安装编译,都是错误的。这里老蒋整理了最为完整的教程,让我们在升级PHP5.3的时候一并安装PDO_MYSQL。

需要注意的:我们默认安装的WDCP是PHP5.2版本,不要急着升级,我们直接下面下面的升级包,升级的时候直接就可以安装PDO_MYSQL。

wget http://soft.itbulu.com/wdcp/php_up53.sh
sh php_up53.sh

执行上面的脚本,我们需要等待之后PHP版本就会升级到5.3,而且我们可以看到探针中已经支持PDO_MYSQL,而且无需修改任何文件


工信部备案:鄂ICP备13013048号